Access Internet/Local Website from Your Windows Mobile Device Emulators

Challenge

If you want to access any website Or You want your locally developed mobile application/web application to be viewed in Windows Device Emulator then you are at the right post.

Solution
  1. Download ActiveSync and install on your local machine where you would like to run Emulator. How to setup ActiveSync?
  2. Open Visual Studio and click on Tools | Connect to Device:

clip_image002

  1. Select Device emulator to run and say connect.

clip_image004

  1. It will open your device emulator:

clip_image006

  1. Verify that ActiveSync is up and running by its symbol in Notification Area.

clip_image008

  1. Open Device Emulator Manager

clip_image010

  1. Currently running Device Emulator Manager will be shown in Green.

clip_image012

  1. Right click and say “Cradle”

clip_image014

  1. As you click on Cradle ActiveSync window will popup. Select Guest Partnership[Or better do cancel it will by default to Guest Mode]. If your Emulator got synced with ActiveSync then Notification Icon will go Green.
  1. Now you are ready to access website.
    1. Internet – Enter your URL.

clip_image016

    1. Local – To Access your Local Website which is running on Cassini(Development Web Server). To access it you need to access it by IP ADDRESS:PORTNUMBER. Please note that you can’t access it by localhost:PORTNO Because localhost points to Emulator’s localhost and it will never go to your machine. You have to see both Emulator and your local machine as a two different devices even though they are running on same machine.

clip_image018
If this blog helped you. Say a big thanks to my friends who always give me a shout whenever they found something challenging like this and inspire me to learn a new things which finally inspires me to pen down on my blog and share with you 🙂
Happy Emulating!
Webliography
Setup ActiveSync
Nice blog – Thanks to this blog
If you have Windows Vista or Later
Accessing Device Emulator Without ActiveSync

Feedback

[polldaddy poll=2276650]

18 Comments

  • Hi,
    I followed all steps and I’m getting access to internet. But when I try to access local website on IIS 6, I have one of these errors on the emulator :
    – The resource cannot be found
    – Application server unavailable
    Help me pleeese !
    Thanks

    • Check your Web server is up and running and also check it from your web browser.
      If everything is fine and still not working check your Event Log entries.
      Thanks,
      Kiran

  • Short and Sweet yet very informative.. Thanks for the post Superman!!!

  • Thank you so much for this post. It has been of immense help.

    • Thanks! – Glad to know that it helped you!
      Happy Reading!
      Cheers,
      Kiran

  • thank you , it really help me and save my time

    • Haider — Glad to know that you found it useful!
      Thanks for your comment — It stimulates!
      Keep sharing, Keep visiting and Keep reading! 🙂
      Sincerely,
      Kiran Patil

  • Fantastic goods from you, man. I’ve understand your stuff previous to and you are just too wonderful. I really like what you have acquired here, certainly like what you are stating and the way in which you say it. You make it entertaining and you still care for to keep it sensible. I can’t wait to read far more from you.
    This is actually a great website.

    • Hello Elton,
      Thank you for the appreciation, it matters a lot!
      Keep visiting! Keep reading! Keep sharing!
      Sincerely.
      Kiran Patil

  • This is really interesting, You are a very skilled blogger.
    I have joined your rss feed and look forward to seeking
    more of your great post. Also, I have shared your web site in my social networks!

Comments are closed.